Browse Source

separate .babelrc for prod/dev, add babel-plugin-lodash (#2829)

custom
Nolan Lawson 5 years ago
committed by Eugen Rochko
parent
commit
37caf0b36e
  1. 17
      .babelrc
  2. 5
      config/webpack/loaders/babel.js
  3. 1
      package.json
  4. 7
      yarn.lock

17
.babelrc

@ -11,8 +11,6 @@
]
],
"plugins": [
"transform-react-jsx-source",
"transform-react-jsx-self",
"transform-decorators-legacy",
"transform-object-rest-spread",
[
@ -21,5 +19,18 @@
"messagesDir": "./build/messages"
}
]
]
],
"env": {
"development": {
"plugins": [
"transform-react-jsx-source",
"transform-react-jsx-self"
]
},
"production": {
"plugins": [
"lodash"
]
}
}
}

5
config/webpack/loaders/babel.js

@ -1,5 +1,8 @@
module.exports = {
test: /\.js(\.erb)?$/,
exclude: /node_modules/,
loader: 'babel-loader'
loader: 'babel-loader',
options: {
forceEnv: process.env.NODE_ENV || 'development'
}
}

1
package.json

@ -108,6 +108,7 @@
"devDependencies": {
"@kadira/storybook": "^2.35.3",
"babel-eslint": "^7.2.2",
"babel-plugin-lodash": "^3.2.11",
"chai": "^3.5.0",
"chai-enzyme": "^0.6.1",
"enzyme": "^2.8.2",

7
yarn.lock

@ -627,6 +627,13 @@ babel-plugin-check-es2015-constants@^6.22.0, babel-plugin-check-es2015-constants
dependencies:
babel-runtime "^6.22.0"
babel-plugin-lodash@^3.2.11:
version "3.2.11"
resolved "https://registry.yarnpkg.com/babel-plugin-lodash/-/babel-plugin-lodash-3.2.11.tgz#21c8fdec9fe1835efaa737873e3902bdd66d5701"
dependencies:
glob "^7.1.1"
lodash "^4.17.2"
babel-plugin-react-docgen@^1.4.2:
version "1.4.2"
resolved "https://registry.yarnpkg.com/babel-plugin-react-docgen/-/babel-plugin-react-docgen-1.4.2.tgz#04c02133b84b6cc182d35de2162f15764da03e7c"

Loading…
Cancel
Save