You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

cryptcheck.gemspec 1.6KB

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # coding: utf-8
  2. lib = File.expand_path('../lib', __FILE__)
  3. $LOAD_PATH.unshift(lib) unless $LOAD_PATH.include?(lib)
  4. Gem::Specification.new do |spec|
  5. spec.name = 'cryptcheck'
  6. spec.version = '2.0.0'
  7. spec.authors = ['Aeris']
  8. spec.email = ['aeris+tls@imirhil.fr']
  9. spec.summary = %q{Check best practices on crypto-stack implementation}
  10. spec.description = %q{Verify if best practices are well implemented on current crypto-stack (TLS & SSH) protocol (HTTPS, SMTP, XMPP, SSH & VPN)}
  11. spec.homepage = 'https://tls.imirhil.fr'
  12. spec.license = 'AGPL-3.0+'
  13. if spec.respond_to?(:metadata)
  14. spec.metadata['allowed_push_host'] = 'TODO: Set to "http://mygemserver.com"'
  15. else
  16. raise 'RubyGems 2.0 or newer is required to protect against public gem pushes.'
  17. end
  18. spec.files = { '*.rb' => %w(lib) }
  19. .collect_concat { |e, ds| ds.collect_concat { |d| Dir[File.join d, '**', e] } }
  20. # spec.bindir = 'bin'
  21. # spec.executables = spec.files.grep(%r{^bin/}) { |f| File.basename(f) }
  22. # spec.test_files = spec.files.grep(%r{^spec/})
  23. spec.require_paths = %w(lib)
  24. spec.add_development_dependency 'bundler'
  25. spec.add_development_dependency 'rake'
  26. spec.add_development_dependency 'rspec'
  27. spec.add_development_dependency 'ffi'
  28. spec.add_development_dependency 'pry-byebug'
  29. spec.add_development_dependency 'pry-rescue'
  30. spec.add_development_dependency 'pry-stack_explorer'
  31. spec.add_dependency 'httparty'
  32. spec.add_dependency 'nokogiri'
  33. spec.add_dependency 'parallel'
  34. spec.add_dependency 'ruby-progressbar'
  35. spec.add_dependency 'colorize'
  36. spec.add_dependency 'awesome_print'
  37. end