Browse Source

Change dependencies for dev

new-scoring
aeris 1 year ago
parent
commit
b83cda618a
2 changed files with 13 additions and 12 deletions
  1. 1
    2
      .gitignore
  2. 12
    10
      cryptcheck.gemspec

+ 1
- 2
.gitignore View File

@@ -1,9 +1,8 @@
1
-*.iml
2 1
 *.gem
3 2
 *.pem
4 3
 .rakeTasks
5
-.idea/
6 4
 /build/
5
+/tmp/
7 6
 /coverage/
8 7
 /db/*.sqlite3
9 8
 /db/schema.rb

+ 12
- 10
cryptcheck.gemspec View File

@@ -26,16 +26,18 @@ Gem::Specification.new do |spec|
26 26
 #	spec.test_files    = spec.files.grep(%r{^spec/})
27 27
 	spec.require_paths = %w(lib)
28 28
 
29
-	spec.add_development_dependency 'bundler', '~> 1.9', '>= 1.9.8'
30
-	spec.add_development_dependency 'rake', '~> 11.2', '>= 11.2.2'
31
-	spec.add_development_dependency 'rspec', '~> 3.2', '>= 3.2.0'
32
-	spec.add_development_dependency 'ffi', '~> 1.9', '>= 1.9.17'
29
+	spec.add_development_dependency 'bundler'
30
+	spec.add_development_dependency 'rake'
31
+	spec.add_development_dependency 'rspec'
32
+	spec.add_development_dependency 'ffi'
33 33
 	spec.add_development_dependency 'pry-byebug'
34
+	spec.add_development_dependency 'pry-rescue'
35
+	spec.add_development_dependency 'pry-stack_explorer'
34 36
 
35
-	spec.add_dependency 'httparty', '~> 0.13', '>= 0.13.3'
36
-	spec.add_dependency 'nokogiri', '~> 1.6', '>= 1.6.6'
37
-	spec.add_dependency 'parallel', '~> 1.3', '>= 1.3.4'
38
-	spec.add_dependency 'ruby-progressbar', '~> 1.7', '>= 1.7.1'
39
-	spec.add_dependency 'colorize', '~> 0.7', '>= 0.7.7'
40
-	spec.add_dependency 'awesome_print', '~> 1.7.0', '>= 1.7.0'
37
+	spec.add_dependency 'httparty'
38
+	spec.add_dependency 'nokogiri'
39
+	spec.add_dependency 'parallel'
40
+	spec.add_dependency 'ruby-progressbar'
41
+	spec.add_dependency 'colorize'
42
+	spec.add_dependency 'awesome_print'
41 43
 end

Loading…
Cancel
Save